CVE-2013-4662 CiviCRM SQL injection vulnerability via Quick Search API
Authenticated users can bypass validation in the Quick Search API to perform SQL injection attacks, potentially accessing or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4662?
CVE-2013-4662 is a medium-severity SQL injection vulnerability in n/a, published on 29 Jan 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.
Weakness: CWE-89
Which versions are affected by CVE-2013-4662?
4 open source packages ship an affected version, including civicrm/civicrm-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
civicrm/civicrm-core Packagist | From 4.2.0 | 4.2.9 |
civicrm/civicrm-core Packagist | From 4.2.0 | 4.2.9 |
civicrm/civicrm-core Packagist | From 4.3.0 | 4.3.3 |
civicrm/civicrm-core Packagist | From 4.3.0 | 4.3.3 |
Products include Civicrm Civicrm.
How do I fix CVE-2013-4662?
Upgrade civicrm/civicrm-core to a fixed version for your release line: 4.2.9 or 4.3.3.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2013-4662 being exploited?
There is no known exploitation of CVE-2013-4662 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-4465-r2hg-v4rj.