# CVE-2013-4662: CiviCRM SQL injection vulnerability via Quick Search API

> Authenticated users can bypass validation in the Quick Search API to perform SQL injection attacks, potentially accessing or modifying database contents.

- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4465-r2hg-v4rj

## What is CVE-2013-4662?

CVE-2013-4662 is a medium-severity SQL injection vulnerability in n/a, published on 29 Jan 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2013-4662?

4 open source packages ship an affected version, including civicrm/civicrm-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `civicrm/civicrm-core` | Packagist | From 4.2.0 | 4.2.9 |
| `civicrm/civicrm-core` | Packagist | From 4.2.0 | 4.2.9 |
| `civicrm/civicrm-core` | Packagist | From 4.3.0 | 4.3.3 |
| `civicrm/civicrm-core` | Packagist | From 4.3.0 | 4.3.3 |

Products: Civicrm Civicrm.

## How do I fix CVE-2013-4662?

Upgrade civicrm/civicrm-core to a fixed version for your release line: 4.2.9 or 4.3.3.

## Is CVE-2013-4662 being exploited?

There is no known exploitation of CVE-2013-4662 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1999022](https://insights.sbomify.com/CVE-2018-1999022/): Code injection in n/a (critical 9.8)
- [CVE-2020-36388](https://insights.sbomify.com/CVE-2020-36388/): File upload in n/a (high 8.8)
- [CVE-2013-5957](https://insights.sbomify.com/CVE-2013-5957/): SQL injection in n/a (high 7.5)
- [CVE-2025-65187](https://insights.sbomify.com/CVE-2025-65187/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2011-5239](https://insights.sbomify.com/CVE-2011-5239/): Weak cryptography in n/a (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4662 and fix it if it is affected.

What it is: CVE-2013-4662 is a medium-severity SQL injection vulnerability in n/a, published on 29 Jan 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-4662 in the wild and no public exploit code.

Affected packages and fixed versions:
- civicrm/civicrm-core (Packagist): affected from 4.2.0; fixed in 4.2.9
- civicrm/civicrm-core (Packagist): affected from 4.2.0; fixed in 4.2.9
- civicrm/civicrm-core (Packagist): affected from 4.3.0; fixed in 4.3.3
- civicrm/civicrm-core (Packagist): affected from 4.3.0; fixed in 4.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4662/ (Markdown: https://insights.sbomify.com/CVE-2013-4662/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4662
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4662
- OSV: https://osv.dev/vulnerability/CVE-2013-4662

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4662/
Summaries are generated and may contain mistakes; the official description above is the record.
