{"answers":{"affected":"4 open source packages ship an affected version, including openid/php-openid and typo3/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4701 in the wild and no public exploit code.","fix":"Upgrade openid/php-openid to 2.3.0 or later.","what":"CVE-2013-4701 is a high-severity vulnerability in n/a, published on 21 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-4701 and fix it if it is affected.\n\nWhat it is: CVE-2013-4701 is a high-severity vulnerability in n/a, published on 21 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-4701 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openid/php-openid (Packagist): affected all versions; fixed in 2.3.0\n- openid/php-openid (Packagist): affected all versions; fixed in 2.3.0\n- typo3/cms (Packagist): affected from 6.2.0; fixed in 6.2.6\n- typo3/cms (Packagist): affected from 6.2.0; fixed in 6.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4701/ (Markdown: https://insights.sbomify.com/CVE-2013-4701/index.md)","id":"CVE-2013-4701","markdown":"https://insights.sbomify.com/CVE-2013-4701/index.md","name":"CVE-2013-4701","record":{"aliases":["GHSA-5qp6-78pr-gv8c","MGASA-2013-0272"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP OpenID Library","requires_auth":"none","summary":"Remote attackers can read arbitrary files, access intranet servers, or cause denial of service via XML External Entity injection in the PHP OpenID Library.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"php-openid","vendor":"janrain"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Auth/Yadis/XML.php in PHP OpenID Library 2.2.2 and earlier allows remote attackers to read arbitrary files, send HTTP requests to intranet servers, or cause a denial of service (CPU and memory consumption) via XRDS data containing an external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PHP OpenID Library Denial of Service vulnerability","id":"CVE-2013-4701","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2013"},"n_packages":4,"n_references":5,"next":{"headline":"Path traversal in n/a","id":"CVE-2013-4702"},"packages":[{"ecosystem":"Packagist","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"openid/php-openid","purl":null,"source":"GHSA-5qp6-78pr-gv8c"},{"ecosystem":"Packagist","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"openid/php-openid","purl":"pkg:composer/openid/php-openid","source":"GHSA-5qp6-78pr-gv8c"},{"ecosystem":"Packagist","fixed":["6.2.6"],"introduced":["6.2.0"],"last_affected":[],"package":"typo3/cms","purl":null,"source":"GHSA-5qp6-78pr-gv8c"},{"ecosystem":"Packagist","fixed":["6.2.6"],"introduced":["6.2.0"],"last_affected":[],"package":"typo3/cms","purl":"pkg:composer/typo3/cms","source":"GHSA-5qp6-78pr-gv8c"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2013-4700"},"products":["n/a"],"published":"2013-08-21","related":[{"cvss_score":8.8,"headline":"Auth bypass in n/a","id":"CVE-2016-2049","kev_date_added":null,"published":"2016-02-01"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2011-3707","kev_date_added":null,"published":"2011-09-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files, access intranet servers, or cause denial of service via XML External Entity injection in the PHP OpenID Library.","url":"https://insights.sbomify.com/CVE-2013-4701/"}