# CVE-2013-4714: Tiki Wiki CMS Groupware Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML into Tiki Wiki CMS, potentially compromising user sessions or data.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Nov 2013
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h7jc-pg2r-mqj4

## What is CVE-2013-4714?

CVE-2013-4714 is a medium-severity cross-site scripting vulnerability in Tiki Tikiwiki Cms\/Groupware, published on 6 Nov 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Tiki Wiki CMS Groupware 6 LTS before 6.13LTS, 9 LTS before 9.7LTS, 10.x before 10.4, and 11.x before 11.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-4714?

8 open source packages ship an affected version, including tikiwiki/tiki-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tikiwiki/tiki-manager` | Packagist | From 10.0 | 10.4 |
| `tikiwiki/tiki-manager` | Packagist | From 10.0 | 10.4 |
| `tikiwiki/tiki-manager` | Packagist | From 11.0 | 11.1 |
| `tikiwiki/tiki-manager` | Packagist | From 11.0 | 11.1 |
| `tikiwiki/tiki-manager` | Packagist | From 6.0 | 6.13 |
| `tikiwiki/tiki-manager` | Packagist | From 6.0 | 6.13 |
| `tikiwiki/tiki-manager` | Packagist | From 9.0 | 9.7 |
| `tikiwiki/tiki-manager` | Packagist | From 9.0 | 9.7 |

Products: Tiki Tikiwiki Cms\/Groupware.

## How do I fix CVE-2013-4714?

Upgrade tikiwiki/tiki-manager to a fixed version for your release line: 10.4, 11.1, 6.13 or 9.7.

## Is CVE-2013-4714 being exploited?

There is no known exploitation of CVE-2013-4714 in the wild and no public exploit code.

## Other vulnerabilities in Tiki Tikiwiki Cms\/Groupware

- [CVE-2008-3653](https://insights.sbomify.com/CVE-2008-3653/): Multiple unspecified vulnerabilities in TikiWiki CMS/Groupware before 2.0 have unknown impact and attack vectors. (critical 10.0)
- [CVE-2007-6529](https://insights.sbomify.com/CVE-2007-6529/): Other in n/a (critical 10.0)
- [CVE-2010-4239](https://insights.sbomify.com/CVE-2010-4239/): Path traversal in CMS Groupware (critical 9.8)
- [CVE-2012-0911](https://insights.sbomify.com/CVE-2012-0911/): Deserialization in n/a (critical 9.8)
- [CVE-2025-34111](https://insights.sbomify.com/CVE-2025-34111/): Tiki Wiki <= 15.1 ELFinder Unauthenticated File Upload RCE (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4714 and fix it if it is affected.

What it is: CVE-2013-4714 is a medium-severity cross-site scripting vulnerability in Tiki Tikiwiki Cms\/Groupware, published on 6 Nov 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-4714 in the wild and no public exploit code.

Affected packages and fixed versions:
- tikiwiki/tiki-manager (Packagist): affected from 10.0; fixed in 10.4
- tikiwiki/tiki-manager (Packagist): affected from 10.0; fixed in 10.4
- tikiwiki/tiki-manager (Packagist): affected from 11.0; fixed in 11.1
- tikiwiki/tiki-manager (Packagist): affected from 11.0; fixed in 11.1
- tikiwiki/tiki-manager (Packagist): affected from 6.0; fixed in 6.13
- tikiwiki/tiki-manager (Packagist): affected from 6.0; fixed in 6.13
- tikiwiki/tiki-manager (Packagist): affected from 9.0; fixed in 9.7
- tikiwiki/tiki-manager (Packagist): affected from 9.0; fixed in 9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4714/ (Markdown: https://insights.sbomify.com/CVE-2013-4714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4714
- OSV: https://osv.dev/vulnerability/CVE-2013-4714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4714/
Summaries are generated and may contain mistakes; the official description above is the record.
