{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4729 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 4.0.4.1 or later.","what":"CVE-2013-4729 is a medium-severity missing authorization vulnerability in Phpmyadmin Phpmyadmin, published on 4 Jul 2013. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-4729 and fix it if it is affected.\n\nWhat it is: CVE-2013-4729 is a medium-severity missing authorization vulnerability in Phpmyadmin Phpmyadmin, published on 4 Jul 2013. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-4729 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.4.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.0.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4729/ (Markdown: https://insights.sbomify.com/CVE-2013-4729/index.md)","id":"CVE-2013-4729","markdown":"https://insights.sbomify.com/CVE-2013-4729/index.md","name":"CVE-2013-4729","record":{"aliases":["DEBIAN-CVE-2013-4729","GHSA-x962-w72p-mv7q"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"low_privilege","summary":"Authenticated users can modify global configuration settings in phpMyAdmin by manipulating input data, potentially bypassing security controls.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"import.php in phpMyAdmin 4.x before 4.0.4.1 does not properly restrict the ability of input data to specify a file format, which allows remote authenticated users to modify the GLOBALS superglobal array, and consequently change the configuration, via a crafted request.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Global variables scope injection vulnerability","id":"CVE-2013-4729","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"missing_authorization","year":"2013"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2013-4730"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.4.1"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-x962-w72p-mv7q"},{"ecosystem":"Packagist","fixed":["4.0.4.1"],"introduced":["4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-x962-w72p-mv7q"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2013-4728"},"products":["n/a"],"published":"2013-07-04","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Authenticated users can modify global configuration settings in phpMyAdmin by manipulating input data, potentially bypassing security controls.","url":"https://insights.sbomify.com/CVE-2013-4729/"}