CVE-2013-4761 Puppet allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service
Remote attackers with local file system access to the Puppet Master can execute arbitrary Ruby programs via the resource_type service.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-4761?
CVE-2013-4761 is a medium-severity code injection vulnerability in Puppet Puppet Enterprise, published on 20 Aug 2013. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Unspecified vulnerability in Puppet 2.7.x before 2.7.23 and 3.2.x before 3.2.4, and Puppet Enterprise 2.8.x before 2.8.3 and 3.0.x before 3.0.1, allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service. NOTE: this vulnerability can only be exploited utilizing unspecified "local file system access" to the Puppet Master.
Which versions are affected by CVE-2013-4761?
4 open source packages ship an affected version, including puppet. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | From 2.7.0 | 2.7.23 |
puppet RubyGems | From 2.7.0 | 2.7.23 |
puppet RubyGems | From 3.2.0 | 3.2.4 |
puppet RubyGems | From 3.2.0 | 3.2.4 |
Products include Puppet Puppet, Puppet Puppet Enterprise, Puppetlabs Puppet.
How do I fix CVE-2013-4761?
Upgrade puppet to a fixed version for your release line: 2.7.23 or 3.2.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2013-4761 being exploited?
There is no known exploitation of CVE-2013-4761 in the wild and no public exploit code.
Other vulnerabilities in Puppet Puppet Enterprise
Sources
Also known as DEBIAN-CVE-2013-4761, GHSA-cj43-9h3w-v976.