# CVE-2013-4791: PrestaShop Stored Cross-Site Scripting Vulnerability

> Low-privilege users can inject persistent XSS via TinyMCE in PrestaShop, potentially leading to session hijacking or malicious script execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-crpg-2mm2-jjqf

## What is CVE-2013-4791?

CVE-2013-4791 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 13 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

PrestaShop before 1.4.11 allows Logistician, translators and other low level profiles/accounts to inject a persistent XSS vector on TinyMCE.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-4791?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 1.4.11 |
| `prestashop/prestashop` | Packagist | All versions | 1.4.11 |

Products: Prestashop Prestashop.

## How do I fix CVE-2013-4791?

Upgrade prestashop/prestashop to 1.4.11 or later.

## Is CVE-2013-4791 being exploited?

There is no known exploitation of CVE-2013-4791 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-4791 and fix it if it is affected.

What it is: CVE-2013-4791 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 13 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-4791 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.4.11
- prestashop/prestashop (Packagist): affected all versions; fixed in 1.4.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-4791/ (Markdown: https://insights.sbomify.com/CVE-2013-4791/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-4791
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-4791
- OSV: https://osv.dev/vulnerability/CVE-2013-4791

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-4791/
Summaries are generated and may contain mistakes; the official description above is the record.
