CVE-2013-4940 YUI Cross-site Scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script or HTML via crafted URLs in the YUI IO Utility component, affecting applications like Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-4940?
CVE-2013-4940 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 26 Jul 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in io.swf in the IO Utility component in Yahoo! YUI 3.10.2, as used in Moodle through 2.1.10, 2.2.x before 2.2.11, 2.3.x before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.1, and other products, allows remote attackers to inject arbitrary web script or HTML via a crafted string in a URL. NOTE: this vulnerability exists because of a CVE-2013-4939 regression.
Weakness: CWE-79
Which versions are affected by CVE-2013-4940?
12 open source packages ship an affected version, including moodle/moodle and yui. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.2.11 |
moodle/moodle Packagist | All versions | 2.2.11 |
moodle/moodle Packagist | From 2.3.0 | 2.3.8 |
moodle/moodle Packagist | From 2.3.0 | 2.3.8 |
moodle/moodle Packagist | From 2.4.0-rc1 | 2.4.5 |
moodle/moodle Packagist | From 2.4.0-rc1 | 2.4.5 |
6 more packages
moodle/moodle Packagist | From 2.5.0-beta | 2.5.1 |
moodle/moodle Packagist | From 2.5.0-beta | 2.5.1 |
yui npm | From 3.0.0 | 3.10.11 |
yui npm | From 3.0.0 | 3.10.11 |
yui npm | From 3.10.12 | 3.10.13 |
yui npm | From 3.10.12 | 3.10.13 |
Products include Moodle Moodle, Yahoo Yui.
How do I fix CVE-2013-4940?
Upgrade moodle/moodle to a fixed version for your release line: 2.2.11, 2.3.8, 2.4.5 or 2.5.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2013-4940 being exploited?
There is no known exploitation of CVE-2013-4940 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-x5hj-47vv-53p8.