{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-4997 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 3.5.8.2 or later.","what":"CVE-2013-4997 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 30 Jul 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-4997 and fix it if it is affected.\n\nWhat it is: CVE-2013-4997 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 30 Jul 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-4997 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.5; fixed in 3.5.8.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.5; fixed in 3.5.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-4997/ (Markdown: https://insights.sbomify.com/CVE-2013-4997/index.md)","id":"CVE-2013-4997","markdown":"https://insights.sbomify.com/CVE-2013-4997/index.md","name":"CVE-2013-4997","record":{"aliases":["DEBIAN-CVE-2013-4997","GHSA-5gh4-v2ch-pcx4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via JavaScript events in phpMyAdmin setup or chart titles, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.5.x before 3.5.8.2 allow remote attackers to inject arbitrary web script or HTML via vectors involving a JavaScript event in (1) an anchor identifier to setup/index.php or (2) a chartTitle (aka chart title) value.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Multiple cross-site scripting (XSS) vulnerabilities","id":"CVE-2013-4997","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"xss","year":"2013"},"n_packages":2,"n_references":1,"next":{"headline":"Information disclosure in n/a","id":"CVE-2013-4998"},"packages":[{"ecosystem":"Packagist","fixed":["3.5.8.2"],"introduced":["3.5"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5gh4-v2ch-pcx4"},{"ecosystem":"Packagist","fixed":["3.5.8.2"],"introduced":["3.5"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5gh4-v2ch-pcx4"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-4996"},"products":["n/a"],"published":"2013-07-30","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via JavaScript events in phpMyAdmin setup or chart titles, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2013-4997/"}