CVE-2013-5002 phpMyAdmin Cross-site scripting (XSS) vulnerability via pageNumber value
Authenticated users can inject arbitrary scripts via crafted parameters in phpMyAdmin, potentially compromising other users' sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-5002?
CVE-2013-5002 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 30 Jul 2013. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in libraries/schema/Export_Relation_Schema.class.php in phpMyAdmin 3.5.x before 3.5.8.2 and 4.0.x before 4.0.4.2 allows remote authenticated users to inject arbitrary web script or HTML via a crafted pageNumber value to schema_export.php.
Weakness: CWE-79
Which versions are affected by CVE-2013-5002?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 3.5 | 3.5.8.2 |
phpmyadmin/phpmyadmin Packagist | From 3.5 | 3.5.8.2 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.4.2 |
phpmyadmin/phpmyadmin Packagist | From 4.0 | 4.0.4.2 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2013-5002?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.5.8.2 or 4.0.4.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2013-5002 being exploited?
There is no known exploitation of CVE-2013-5002 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2013-5002, GHSA-p632-5w74-x8xx.