# CVE-2013-5647: Sounder Contains Arbitrary Command Execution Vulnerability

> Remote attackers can execute arbitrary commands via shell metacharacters in filenames using the sounder Ruby gem.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2013
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rfmf-rx8w-935w

## What is CVE-2013-5647?

CVE-2013-5647 is a high-severity command injection vulnerability in n/a, published on 29 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/sounder/sound.rb in the sounder gem 1.0.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2013-5647?

2 open source packages ship an affected version, including sounder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sounder` | RubyGems | All versions | 1.0.2 |
| `sounder` | RubyGems | All versions | 1.0.2 |

Products: Adam Zaninovich Sounder.

## How do I fix CVE-2013-5647?

Upgrade sounder to 1.0.2 or later.

## Is CVE-2013-5647 being exploited?

There is no known exploitation of CVE-2013-5647 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-5647 and fix it if it is affected.

What it is: CVE-2013-5647 is a high-severity command injection vulnerability in n/a, published on 29 Aug 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-5647 in the wild and no public exploit code.

Affected packages and fixed versions:
- sounder (RubyGems): affected all versions; fixed in 1.0.2
- sounder (RubyGems): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-5647/ (Markdown: https://insights.sbomify.com/CVE-2013-5647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-5647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-5647
- OSV: https://osv.dev/vulnerability/CVE-2013-5647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-5647/
Summaries are generated and may contain mistakes; the official description above is the record.
