{"answers":{"affected":"4 open source packages ship an affected version, including dragonfly and fog-dragonfly. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-5671 in the wild and no public exploit code.","fix":"Upgrade dragonfly to 1.0.0 or later.","what":"CVE-2013-5671 is a high-severity command injection vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-5671 and fix it if it is affected.\n\nWhat it is: CVE-2013-5671 is a high-severity command injection vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-5671 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dragonfly (RubyGems): affected all versions; fixed in 1.0.0\n- dragonfly (RubyGems): affected all versions; fixed in 1.0.0\n- fog-dragonfly (RubyGems): affected all versions up to 0.9.15; no fix listed\n- fog-dragonfly (RubyGems): affected all versions up to 0.9.15; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-5671/ (Markdown: https://insights.sbomify.com/CVE-2013-5671/index.md)","id":"CVE-2013-5671","markdown":"https://insights.sbomify.com/CVE-2013-5671/index.md","name":"CVE-2013-5671","record":{"aliases":["GHSA-qrgf-jqqm-x7xv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby gem library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via unspecified vectors in the fog-dragonfly Ruby gem.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fog-dragonfly","vendor":"mark_evans"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in dragonfly gem","id":"CVE-2013-5671","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2013"},"n_packages":4,"n_references":5,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2013-5672"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"dragonfly","purl":null,"source":"GHSA-qrgf-jqqm-x7xv"},{"ecosystem":"RubyGems","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"dragonfly","purl":"pkg:gem/dragonfly","source":"GHSA-qrgf-jqqm-x7xv"},{"ecosystem":"RubyGems","fixed":[],"introduced":["0"],"last_affected":["0.9.15"],"package":"fog-dragonfly","purl":null,"source":"GHSA-qrgf-jqqm-x7xv"},{"ecosystem":"RubyGems","fixed":[],"introduced":["0"],"last_affected":["0.9.15"],"package":"fog-dragonfly","purl":"pkg:gem/fog-dragonfly","source":"GHSA-qrgf-jqqm-x7xv"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-5670"},"products":["n/a"],"published":"2014-05-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via unspecified vectors in the fog-dragonfly Ruby gem.","url":"https://insights.sbomify.com/CVE-2013-5671/"}