# CVE-2013-5671: Code injection in dragonfly gem

> Remote attackers can execute arbitrary commands via unspecified vectors in the fog-dragonfly Ruby gem.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qrgf-jqqm-x7xv

## What is CVE-2013-5671?

CVE-2013-5671 is a high-severity command injection vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.

## Which versions are affected by CVE-2013-5671?

4 open source packages ship an affected version, including dragonfly and fog-dragonfly. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dragonfly` | RubyGems | All versions | 1.0.0 |
| `dragonfly` | RubyGems | All versions | 1.0.0 |
| `fog-dragonfly` | RubyGems | All versions to 0.9.15 | None |
| `fog-dragonfly` | RubyGems | All versions to 0.9.15 | None |

Products: Mark Evans Fog-Dragonfly.

## How do I fix CVE-2013-5671?

Upgrade dragonfly to 1.0.0 or later.

## Is CVE-2013-5671 being exploited?

There is no known exploitation of CVE-2013-5671 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-5671 and fix it if it is affected.

What it is: CVE-2013-5671 is a high-severity command injection vulnerability in n/a, published on 12 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-5671 in the wild and no public exploit code.

Affected packages and fixed versions:
- dragonfly (RubyGems): affected all versions; fixed in 1.0.0
- dragonfly (RubyGems): affected all versions; fixed in 1.0.0
- fog-dragonfly (RubyGems): affected all versions up to 0.9.15; no fix listed
- fog-dragonfly (RubyGems): affected all versions up to 0.9.15; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-5671/ (Markdown: https://insights.sbomify.com/CVE-2013-5671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-5671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-5671
- OSV: https://osv.dev/vulnerability/CVE-2013-5671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-5671/
Summaries are generated and may contain mistakes; the official description above is the record.
