# CVE-2013-5679: Missing Cryptographic Step in OWASP Enterprise Security API for Java

> Remote attackers can bypass cryptographic protections in the OWASP ESAPI Java library by tampering with serialized ciphertext due to improper MAC handling.

- **Severity:** Low 2.6 (`AV:L/AC:H/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2013
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-jcp9-796g-pv9p, MGASA-2015-0064

## What is CVE-2013-5679?

CVE-2013-5679 is a low-severity vulnerability in n/a, published on 30 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The authenticated-encryption feature in the symmetric-encryption implementation in the OWASP Enterprise Security API (ESAPI) for Java 2.x before 2.1.0 does not properly resist tampering with serialized ciphertext, which makes it easier for remote attackers to bypass intended cryptographic protection mechanisms via an attack against authenticity in the default configuration, involving a null MAC and a zero MAC length.

Weakness: CWE-310

## Which versions are affected by CVE-2013-5679?

2 open source packages ship an affected version, including org.owasp.esapi:esapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp.esapi:esapi` | Maven | From 2.0.0 | 2.1.0 |
| `org.owasp.esapi:esapi` | Maven | From 2.0.0 | 2.1.0 |

Products: Owasp Enterprise Security Api.

## How do I fix CVE-2013-5679?

Upgrade org.owasp.esapi:esapi to 2.1.0 or later.

## Is CVE-2013-5679 being exploited?

There is no known exploitation of CVE-2013-5679 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-5960](https://insights.sbomify.com/CVE-2013-5960/): Missing Cryptographic Step in OWASP Enterprise Security API for Java (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-5679 and fix it if it is affected.

What it is: CVE-2013-5679 is a low-severity vulnerability in n/a, published on 30 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-5679 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.owasp.esapi:esapi (Maven): affected from 2.0.0; fixed in 2.1.0
- org.owasp.esapi:esapi (Maven): affected from 2.0.0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-5679/ (Markdown: https://insights.sbomify.com/CVE-2013-5679/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-5679
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-5679
- OSV: https://osv.dev/vulnerability/CVE-2013-5679

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-5679/
Summaries are generated and may contain mistakes; the official description above is the record.
