CVE-2013-5750 FriendsOfSymfony FOSUserBundle denial of service via login form
Remote attackers can cause denial of service via CPU exhaustion by submitting long passwords to the login form.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-5750?
CVE-2013-5750 is a medium-severity denial of service vulnerability in n/a, published on 25 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The login form in the FriendsOfSymfony FOSUserBundle bundle before 1.3.3 for Symfony allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation.
Weakness: CWE-399
Which versions are affected by CVE-2013-5750?
4 open source packages ship an affected version, including friendsofsymfony/user-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
friendsofsymfony/user-bundle Packagist | From 1.2.0 | 1.2.5 |
friendsofsymfony/user-bundle Packagist | From 1.2.0 | 1.2.5 |
friendsofsymfony/user-bundle Packagist | From 1.3.0 | 1.3.3 |
friendsofsymfony/user-bundle Packagist | From 1.3.0 | 1.3.3 |
Products include Friends of Symfony Project Fosuserbundle.
How do I fix CVE-2013-5750?
Upgrade friendsofsymfony/user-bundle to a fixed version for your release line: 1.2.5 or 1.3.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-5750 being exploited?
There is no known exploitation of CVE-2013-5750 in the wild and no public exploit code.
Sources
Also known as GHSA-9mpf-g3fc-9rgv.