{"answers":{"affected":"4 open source packages ship an affected version, including friendsofsymfony/user-bundle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-5750 in the wild and no public exploit code.","fix":"Upgrade friendsofsymfony/user-bundle to a fixed version for your release line: 1.2.5 or 1.3.3.","what":"CVE-2013-5750 is a medium-severity denial of service vulnerability in n/a, published on 25 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-5750 and fix it if it is affected.\n\nWhat it is: CVE-2013-5750 is a medium-severity denial of service vulnerability in n/a, published on 25 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-5750 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- friendsofsymfony/user-bundle (Packagist): affected from 1.2.0; fixed in 1.2.5\n- friendsofsymfony/user-bundle (Packagist): affected from 1.2.0; fixed in 1.2.5\n- friendsofsymfony/user-bundle (Packagist): affected from 1.3.0; fixed in 1.3.3\n- friendsofsymfony/user-bundle (Packagist): affected from 1.3.0; fixed in 1.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-5750/ (Markdown: https://insights.sbomify.com/CVE-2013-5750/index.md)","id":"CVE-2013-5750","markdown":"https://insights.sbomify.com/CVE-2013-5750/index.md","name":"CVE-2013-5750","record":{"aliases":["GHSA-9mpf-g3fc-9rgv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Symfony User Bundle","requires_auth":"none","summary":"Remote attackers can cause denial of service via CPU exhaustion by submitting long passwords to the login form.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fosuserbundle","vendor":"friends_of_symfony_project"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"The login form in the FriendsOfSymfony FOSUserBundle bundle before 1.3.3 for Symfony allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"FriendsOfSymfony FOSUserBundle denial of service via login form","id":"CVE-2013-5750","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2013"},"n_packages":4,"n_references":1,"next":{"headline":"Path traversal in n/a","id":"CVE-2013-5751"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.5"],"introduced":["1.2.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":null,"source":"GHSA-9mpf-g3fc-9rgv"},{"ecosystem":"Packagist","fixed":["1.2.5"],"introduced":["1.2.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":"pkg:composer/friendsofsymfony/user-bundle","source":"GHSA-9mpf-g3fc-9rgv"},{"ecosystem":"Packagist","fixed":["1.3.3"],"introduced":["1.3.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":null,"source":"GHSA-9mpf-g3fc-9rgv"},{"ecosystem":"Packagist","fixed":["1.3.3"],"introduced":["1.3.0"],"last_affected":[],"package":"friendsofsymfony/user-bundle","purl":"pkg:composer/friendsofsymfony/user-bundle","source":"GHSA-9mpf-g3fc-9rgv"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2013-5749"},"products":["n/a"],"published":"2013-09-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service via CPU exhaustion by submitting long passwords to the login form.","url":"https://insights.sbomify.com/CVE-2013-5750/"}