CVE-2013-5823 Apache XML Security For Java vulnerable to Infinite Loop
Remote attackers can cause a denial of service in Oracle Java SE and JRockit via unspecified security-related vectors.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-5823?
CVE-2013-5823 is a medium-severity denial of service vulnerability in Oracle Jdk, published on 16 Oct 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Unspecified vulnerability in Oracle Java SE 7u40 and earlier, Java SE 6u60 and earlier, JRockit R28.2.8 and earlier, JRockit R27.7.6 and earlier, and Java SE Embedded 7u40 and earlier allows remote attackers to affect availability via unknown vectors related to Security.
Which versions are affected by CVE-2013-5823?
4 open source packages ship an affected version, including org.apache.santuario:xmlsec. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.santuario:xmlsec Maven | From 1.4.0 | 1.4.8 |
org.apache.santuario:xmlsec Maven | From 1.4.0 | 1.4.8 |
org.apache.santuario:xmlsec Maven | From 1.5.0 | 1.5.3 |
org.apache.santuario:xmlsec Maven | From 1.5.0 | 1.5.3 |
Products include Oracle Jdk, Oracle Jre, Oracle Jrockit, Sun Jdk, Sun Jre.
How do I fix CVE-2013-5823?
Upgrade org.apache.santuario:xmlsec to a fixed version for your release line: 1.4.8 or 1.5.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-5823 being exploited?
There is no known exploitation of CVE-2013-5823 in the wild and no public exploit code.
Other vulnerabilities in Oracle Jdk
Sources
Also known as GHSA-8gwc-x7mg-7p7p.