# CVE-2013-5942: graphite-web is vulnerable to Remote Code Execution

> Remote attackers can execute arbitrary code on Graphite servers by sending crafted serialized objects due to unsafe pickle usage.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2013
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2013-5942, GHSA-ch3j-w953-hfcm, PYSEC-2013-34

## What is CVE-2013-5942?

CVE-2013-5942 is a medium-severity unsafe deserialization vulnerability in n/a, published on 27 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Graphite 0.9.5 through 0.9.10 uses the pickle Python module unsafely, which allows remote attackers to execute arbitrary code via a crafted serialized object, related to (1) remote_storage.py, (2) storage.py, (3) render/datalib.py, and (4) whitelist/views.py, a different vulnerability than CVE-2013-5093.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2013-5942?

3 open source packages ship an affected version, including graphite-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `graphite-web` | PyPI | From 0.9.5 | 0.9.11 |
| `graphite-web` | PyPI | From 0.9.5 | 0.9.11 |
| `graphite-web` | PyPI | From 0.9.5 | 0.9.11 |

Products: Graphite Project Graphite.

## How do I fix CVE-2013-5942?

Upgrade graphite-web to 0.9.11 or later.

## Is CVE-2013-5942 being exploited?

There is no known exploitation of CVE-2013-5942 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-18638](https://insights.sbomify.com/CVE-2017-18638/): graphite.composer.views.send_email vulnerable to SSRF (high 7.5)
- [CVE-2013-5093](https://insights.sbomify.com/CVE-2013-5093/): graphite-web is vulnerable to Remote Code Execution via renderLocalView function (medium 6.8)
- [CVE-2013-5943](https://insights.sbomify.com/CVE-2013-5943/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2022-4728](https://insights.sbomify.com/CVE-2022-4728/): Graphite Web Cookie cross site scripting (low 3.5)
- [CVE-2022-4729](https://insights.sbomify.com/CVE-2022-4729/): Graphite Web Template Name cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-5942 and fix it if it is affected.

What it is: CVE-2013-5942 is a medium-severity unsafe deserialization vulnerability in n/a, published on 27 Sep 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-5942 in the wild and no public exploit code.

Affected packages and fixed versions:
- graphite-web (PyPI): affected from 0.9.5; fixed in 0.9.11
- graphite-web (PyPI): affected from 0.9.5; fixed in 0.9.11
- graphite-web (PyPI): affected from 0.9.5; fixed in 0.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-5942/ (Markdown: https://insights.sbomify.com/CVE-2013-5942/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-5942
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-5942
- OSV: https://osv.dev/vulnerability/CVE-2013-5942

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-5942/
Summaries are generated and may contain mistakes; the official description above is the record.
