# CVE-2013-5943: Cross-site scripting in n/a

> Remote attackers can inject arbitrary web script or HTML into Graphite, potentially compromising user sessions or data.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Sep 2013
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2013-5943, GHSA-jqjf-6p78-286m, PYSEC-2013-4

## What is CVE-2013-5943?

CVE-2013-5943 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Sep 2013. It can be exploited over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Graphite before 0.9.11 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-5943?

1 open source package ship an affected version, including graphite-web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `graphite-web` | PyPI | All versions | 0.9.11 |

Products: Graphite Project Graphite.

## How do I fix CVE-2013-5943?

Upgrade graphite-web to 0.9.11 or later.

## Is CVE-2013-5943 being exploited?

There is no known exploitation of CVE-2013-5943 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-18638](https://insights.sbomify.com/CVE-2017-18638/): graphite.composer.views.send_email vulnerable to SSRF (high 7.5)
- [CVE-2013-5093](https://insights.sbomify.com/CVE-2013-5093/): graphite-web is vulnerable to Remote Code Execution via renderLocalView function (medium 6.8)
- [CVE-2013-5942](https://insights.sbomify.com/CVE-2013-5942/): graphite-web is vulnerable to Remote Code Execution (medium 6.8)
- [CVE-2022-4728](https://insights.sbomify.com/CVE-2022-4728/): Graphite Web Cookie cross site scripting (low 3.5)
- [CVE-2022-4729](https://insights.sbomify.com/CVE-2022-4729/): Graphite Web Template Name cross site scripting (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-5943 and fix it if it is affected.

What it is: CVE-2013-5943 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Sep 2013. It can be exploited over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-5943 in the wild and no public exploit code.

Affected packages and fixed versions:
- graphite-web (PyPI): affected all versions; fixed in 0.9.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-5943/ (Markdown: https://insights.sbomify.com/CVE-2013-5943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-5943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-5943
- OSV: https://osv.dev/vulnerability/CVE-2013-5943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-5943/
Summaries are generated and may contain mistakes; the official description above is the record.
