CVE-2013-5958 Symfony Denial of Service Via Long Password Hashing
Remote attackers can cause denial of service via CPU exhaustion by submitting long passwords to the Symfony Security component.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2013-5958?
CVE-2013-5958 is a medium-severity denial of service vulnerability in Sensiolabs Symfony, published on 27 Dec 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.
Weakness: CWE-399
Which versions are affected by CVE-2013-5958?
18 open source packages ship an affected version, including symfony/security, symfony/polyfill and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security Packagist | From 2.0.0 | 2.0.25 |
symfony/security Packagist | From 2.0.0 | 2.0.25 |
symfony/security Packagist | From 2.1.0 | 2.1.13 |
symfony/security Packagist | From 2.1.0 | 2.1.13 |
symfony/security Packagist | From 2.2.0 | 2.2.9 |
symfony/security Packagist | From 2.2.0 | 2.2.9 |
12 more packages
symfony/security Packagist | From 2.3.0 | 2.3.6 |
symfony/security Packagist | From 2.3.0 | 2.3.6 |
symfony/polyfill Packagist | From 1.0.0 | 1.10.0 |
symfony/polyfill Packagist | From 1.0.0 | 1.10.0 |
symfony/symfony Packagist | From 2.0.0 | 2.0.25 |
symfony/symfony Packagist | From 2.0.0 | 2.0.25 |
symfony/symfony Packagist | From 2.1.0 | 2.1.13 |
symfony/symfony Packagist | From 2.1.0 | 2.1.13 |
symfony/symfony Packagist | From 2.2.0 | 2.2.9 |
symfony/symfony Packagist | From 2.2.0 | 2.2.9 |
symfony/symfony Packagist | From 2.3.0 | 2.3.6 |
symfony/symfony Packagist | From 2.3.0 | 2.3.6 |
Products include Sensiolabs Symfony.
How do I fix CVE-2013-5958?
Upgrade symfony/security to a fixed version for your release line: 2.0.25, 2.1.13, 2.2.9 or 2.3.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2013-5958 being exploited?
There is no known exploitation of CVE-2013-5958 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as GHSA-cr49-fx2v-9p57.