# CVE-2013-6044: Django cross-site scripting (XSS) vulnerability via is_safe_url function

> Attackers can inject malicious scripts via unsafe URL schemes in Django applications, potentially leading to cross-site scripting attacks.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2013
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-6044, DSA-2740-1, GHSA-9cwg-mhxf-hh59, PYSEC-2013-21

## What is CVE-2013-6044?

CVE-2013-6044 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 4 Oct 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The is_safe_url function in utils/http.py in Django 1.4.x before 1.4.6, 1.5.x before 1.5.2, and 1.6 before beta 2 treats a URL's scheme as safe even if it is not HTTP or HTTPS, which might introduce cross-site scripting (XSS) or other vulnerabilities into Django applications that use this function, as demonstrated by "the login view in django.contrib.auth.views" and the javascript: scheme.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-6044?

5 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 1.4 | 1.4.6, 1.5.2 |
| `django` | PyPI | From 1.4 | 1.4.6 |
| `django` | PyPI | From 1.5 | 1.5.2 |
| `Django` | PyPI | From 1.4 | 1.4.6 |
| `Django` | PyPI | From 1.5 | 1.5.2 |

Products: Djangoproject Django.

## How do I fix CVE-2013-6044?

Upgrade django to a fixed version for your release line: 1.4.6 or 1.5.2.

## Is CVE-2013-6044 being exploited?

There is no known exploitation of CVE-2013-6044 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6044 and fix it if it is affected.

What it is: CVE-2013-6044 is a medium-severity cross-site scripting vulnerability in Djangoproject Django, published on 4 Oct 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-6044 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 1.4; fixed in 1.4.6, 1.5.2
- django (PyPI): affected from 1.4; fixed in 1.4.6
- django (PyPI): affected from 1.5; fixed in 1.5.2
- Django (PyPI): affected from 1.4; fixed in 1.4.6
- Django (PyPI): affected from 1.5; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6044/ (Markdown: https://insights.sbomify.com/CVE-2013-6044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6044
- OSV: https://osv.dev/vulnerability/CVE-2013-6044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6044/
Summaries are generated and may contain mistakes; the official description above is the record.
