# CVE-2013-6288: Apache Solr for TYPO3 (solr) extension is vulnerable to Insecure Unserialize

> An insecure deserialization vulnerability in the Apache Solr extension for TYPO3 allows remote attackers to execute arbitrary code.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 28 Oct 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7m7g-jq4m-98w5

## What is CVE-2013-6288?

CVE-2013-6288 is a critical unsafe deserialization vulnerability in n/a, published on 28 Oct 2013. It can be exploited over the network.

### Official description

Unspecified vulnerability in the Apache Solr for TYPO3 (solr) extension before 2.8.3 for TYPO3 has unknown impact and remote attack vectors, related to "Insecure Unserialize."

## Which versions are affected by CVE-2013-6288?

2 open source packages ship an affected version, including apache-solr-for-typo3/solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-solr-for-typo3/solr` | Packagist | All versions | 2.8.3 |
| `apache-solr-for-typo3/solr` | Packagist | All versions | 2.8.3 |

Products: Ingo Renner Apache Solr.

## How do I fix CVE-2013-6288?

Upgrade apache-solr-for-typo3/solr to 2.8.3 or later.

## Is CVE-2013-6288 being exploited?

There is no known exploitation of CVE-2013-6288 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-6289](https://insights.sbomify.com/CVE-2013-6289/): Apache Solr for TYPO3 (solr) extension is vulnerable to Cross-site scripting (XSS) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6288 and fix it if it is affected.

What it is: CVE-2013-6288 is a critical unsafe deserialization vulnerability in n/a, published on 28 Oct 2013. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2013-6288 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-solr-for-typo3/solr (Packagist): affected all versions; fixed in 2.8.3
- apache-solr-for-typo3/solr (Packagist): affected all versions; fixed in 2.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6288/ (Markdown: https://insights.sbomify.com/CVE-2013-6288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6288
- OSV: https://osv.dev/vulnerability/CVE-2013-6288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6288/
Summaries are generated and may contain mistakes; the official description above is the record.
