{"answers":{"affected":"2 open source packages ship an affected version, including libyaml. It affects 6 products.","exploited":"There is no known exploitation of CVE-2013-6393 in the wild and no public exploit code.","fix":"Upgrade libyaml to 0.2.3 or later.","what":"CVE-2013-6393 is a medium-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 6 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-6393 and fix it if it is affected.\n\nWhat it is: CVE-2013-6393 is a medium-severity memory corruption vulnerability in Canonical Ubuntu Linux, published on 6 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-6393 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libyaml (npm): affected all versions; fixed in 0.2.3\n- libyaml (npm): affected all versions; fixed in 0.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-6393/ (Markdown: https://insights.sbomify.com/CVE-2013-6393/index.md)","id":"CVE-2013-6393","markdown":"https://insights.sbomify.com/CVE-2013-6393/index.md","name":"CVE-2013-6393","record":{"aliases":["DEBIAN-CVE-2013-6393","DSA-2850-1","DSA-2870-1","GHSA-m75h-cghq-c8h5","MGASA-2014-0040"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"YAML parsing library","requires_auth":"none","summary":"Remote attackers can cause denial of service or execute arbitrary code via crafted YAML tags due to a heap-based buffer overflow in LibYAML.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"leap","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse"},{"product":"libyaml","vendor":"pyyaml"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The yaml_parser_scan_tag_uri function in scanner.c in LibYAML before 0.1.5 performs an incorrect cast, which allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted tags in a YAML document, which triggers a heap-based buffer overflow.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Heap Based Buffer Overflow in libyaml","id":"CVE-2013-6393","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","opensuse:leap","opensuse:opensuse","redhat:openstack"],"type":"memory_corruption","year":"2013"},"n_packages":2,"n_references":21,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2013-6394"},"packages":[{"ecosystem":"npm","fixed":["0.2.3"],"introduced":["0"],"last_affected":[],"package":"libyaml","purl":null,"source":"GHSA-m75h-cghq-c8h5"},{"ecosystem":"npm","fixed":["0.2.3"],"introduced":["0"],"last_affected":[],"package":"libyaml","purl":"pkg:npm/libyaml","source":"GHSA-m75h-cghq-c8h5"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2013-6392"},"products":["n/a"],"published":"2014-02-06","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service or execute arbitrary code via crafted YAML tags due to a heap-based buffer overflow in LibYAML.","url":"https://insights.sbomify.com/CVE-2013-6393/"}