CVE-2013-6414 actionpack Improper Input Validation vulnerability

Medium 5.0 Published Updated

Remote attackers can cause denial of service via memory consumption by sending headers with invalid MIME types in Ruby on Rails.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-6414?

CVE-2013-6414 is a medium-severity denial of service vulnerability in Rubyonrails Rails, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

actionpack/lib/action_view/lookup_context.rb in Action View in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to cause a denial of service (memory consumption) via a header containing an invalid MIME type that leads to excessive caching.

Weakness: CWE-20

Which versions are affected by CVE-2013-6414?

4 open source packages ship an affected version, including actionpack. It affects 2 products.

PackageAffectedFixed in
actionpack RubyGemsFrom 3.0.03.2.16
actionpack RubyGemsFrom 3.0.03.2.16
actionpack RubyGemsFrom 4.0.04.0.2
actionpack RubyGemsFrom 4.0.04.0.2

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2013-6414?

Upgrade actionpack to a fixed version for your release line: 3.2.16 or 4.0.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2013-6414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-6414 exists.

Public exploit code: 1 Metasploit module.

All Rubyonrails Rails vulnerabilities

Sources

Also known as GHSA-mpxf-gcw2-pw5q.

Is CVE-2013-6414 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free