CVE-2013-6415 actionpack vulnerable to Cross-site Scripting

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via the unit parameter in the number_to_currency helper, affecting Ruby on Rails applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2013-6415?

CVE-2013-6415 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the number_to_currency helper in actionpack/lib/action_view/helpers/number_helper.rb in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via the unit parameter.

Weakness: CWE-79

Which versions are affected by CVE-2013-6415?

4 open source packages ship an affected version, including actionpack. It affects 2 products.

PackageAffectedFixed in
actionpack RubyGemsFrom 3.0.03.2.16
actionpack RubyGemsFrom 3.0.03.2.16
actionpack RubyGemsFrom 4.0.04.0.2
actionpack RubyGemsFrom 4.0.04.0.2

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2013-6415?

Upgrade actionpack to a fixed version for your release line: 3.2.16 or 4.0.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2013-6415 being exploited?

There is no known exploitation of CVE-2013-6415 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as GHSA-6h5q-96hp-9jgm.

Is CVE-2013-6415 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free