# CVE-2013-6417: actionpack allows bypass of database-query restrictions

> Remote attackers can bypass database restrictions and manipulate queries via crafted requests in Ruby on Rails applications using specific Rack middleware.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wpw7-wxjm-cw8r

## What is CVE-2013-6417?

CVE-2013-6417 is a medium-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

actionpack/lib/action_dispatch/http/request.rb in Ruby on Rails before 3.2.16 and 4.x before 4.0.2 does not properly consider differences in parameter handling between the Active Record component and the JSON implementation, which allows remote attackers to bypass intended database-query restrictions and perform NULL checks or trigger missing WHERE clauses via a crafted request that leverages (1) third-party Rack middleware or (2) custom Rack middleware.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-0155.

Weakness: CWE-264

## Which versions are affected by CVE-2013-6417?

4 open source packages ship an affected version, including actionpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.16 |
| `actionpack` | RubyGems | From 3.0.0 | 3.2.16 |
| `actionpack` | RubyGems | From 4.0.0 | 4.0.2 |
| `actionpack` | RubyGems | From 4.0.0 | 4.0.2 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2013-6417?

Upgrade actionpack to a fixed version for your release line: 3.2.16 or 4.0.2.

## Is CVE-2013-6417 being exploited?

There is no known exploitation of CVE-2013-6417 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6417 and fix it if it is affected.

What it is: CVE-2013-6417 is a medium-severity SQL injection vulnerability in Rubyonrails Rails, published on 7 Dec 2013. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-6417 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.16
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.2.16
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.2
- actionpack (RubyGems): affected from 4.0.0; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6417/ (Markdown: https://insights.sbomify.com/CVE-2013-6417/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6417
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6417
- OSV: https://osv.dev/vulnerability/CVE-2013-6417

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6417/
Summaries are generated and may contain mistakes; the official description above is the record.
