{"answers":{"affected":"3 open source packages ship an affected version, including pywbem. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-6418 in the wild and no public exploit code.","fix":"Upgrade pywbem to 0.8.1 or later.","what":"CVE-2013-6418 is a medium-severity vulnerability in n/a, published on 5 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-6418 and fix it if it is affected.\n\nWhat it is: CVE-2013-6418 is a medium-severity vulnerability in n/a, published on 5 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-6418 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pywbem (PyPI): affected all versions; fixed in 0.8.1\n- pywbem (PyPI): affected all versions; fixed in 0.8.1\n- pywbem (PyPI): affected all versions; fixed in 0.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-6418/ (Markdown: https://insights.sbomify.com/CVE-2013-6418/index.md)","id":"CVE-2013-6418","markdown":"https://insights.sbomify.com/CVE-2013-6418/index.md","name":"CVE-2013-6418","record":{"aliases":["AZL-41410","AZL-45129","GHSA-f9q5-46qg-74x4","PYSEC-2014-93","openSUSE-SU-2024:11263-1","openSUSE-SU-2024:13977-1","openSUSE-SU-2026:12035-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python WBEM library","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof peers by exploiting improper X.509 certificate validation in the PyWBEM library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pywbem","vendor":"pywbem_project"}],"cvss":{"score":5.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"PyWBEM 0.7 and earlier uses a separate connection to validate X.509 certificates, which allows man-in-the-middle attackers to spoof a peer via an arbitrary certificate.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PyWBEM TOCTOU vulnerability in certificate validation","id":"CVE-2013-6418","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2013"},"n_packages":6,"n_references":8,"next":{"headline":"OpenStack Nova Router metadata queries are not restricted by tenant","id":"CVE-2013-6419"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"pywbem","purl":null,"source":"GHSA-f9q5-46qg-74x4"},{"ecosystem":"PyPI","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"pywbem","purl":"pkg:pypi/pywbem","source":"GHSA-f9q5-46qg-74x4"},{"ecosystem":"PyPI","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"pywbem","purl":"pkg:pypi/pywbem","source":"PYSEC-2014-93"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.1.1-2.7"],"introduced":["0"],"last_affected":[],"package":"python-pywbem","purl":"pkg:rpm/opensuse/python-pywbem\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11263-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.7.2-1.1"],"introduced":["0"],"last_affected":[],"package":"python-pywbem","purl":"pkg:rpm/opensuse/python-pywbem\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13977-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.8.1-2.5"],"introduced":["0"],"last_affected":[],"package":"python-pywbem","purl":"pkg:rpm/opensuse/python-pywbem\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12035-1"}],"prev":{"headline":"actionpack allows bypass of database-query restrictions","id":"CVE-2013-6417"},"products":["n/a"],"published":"2014-05-05","related":[{"cvss_score":5.8,"headline":"PyWBEM TOCTOU vulnerability in certificate validation","id":"CVE-2013-6444","kev_date_added":null,"published":"2014-05-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof peers by exploiting improper X.509 certificate validation in the PyWBEM library.","url":"https://insights.sbomify.com/CVE-2013-6418/"}