# CVE-2013-6418: PyWBEM TOCTOU vulnerability in certificate validation

> Man-in-the-middle attackers can spoof peers by exploiting improper X.509 certificate validation in the PyWBEM library.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** AZL-41410, AZL-45129, GHSA-f9q5-46qg-74x4, PYSEC-2014-93, openSUSE-SU-2024:11263-1, openSUSE-SU-2024:13977-1, openSUSE-SU-2026:12035-1

## What is CVE-2013-6418?

CVE-2013-6418 is a medium-severity vulnerability in n/a, published on 5 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyWBEM 0.7 and earlier uses a separate connection to validate X.509 certificates, which allows man-in-the-middle attackers to spoof a peer via an arbitrary certificate.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-6418?

3 open source packages ship an affected version, including pywbem. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pywbem` | PyPI | All versions | 0.8.1 |
| `pywbem` | PyPI | All versions | 0.8.1 |
| `pywbem` | PyPI | All versions | 0.8.1 |
| `python-pywbem` | openSUSE:Tumbleweed | All versions | 1.1.1-2.7 |
| `python-pywbem` | openSUSE:Tumbleweed | All versions | 1.7.2-1.1 |
| `python-pywbem` | openSUSE:Tumbleweed | All versions | 1.8.1-2.5 |

Products: Pywbem Project Pywbem.

## How do I fix CVE-2013-6418?

Upgrade pywbem to 0.8.1 or later.

## Is CVE-2013-6418 being exploited?

There is no known exploitation of CVE-2013-6418 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-6444](https://insights.sbomify.com/CVE-2013-6444/): PyWBEM TOCTOU vulnerability in certificate validation (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6418 and fix it if it is affected.

What it is: CVE-2013-6418 is a medium-severity vulnerability in n/a, published on 5 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-6418 in the wild and no public exploit code.

Affected packages and fixed versions:
- pywbem (PyPI): affected all versions; fixed in 0.8.1
- pywbem (PyPI): affected all versions; fixed in 0.8.1
- pywbem (PyPI): affected all versions; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6418/ (Markdown: https://insights.sbomify.com/CVE-2013-6418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6418
- OSV: https://osv.dev/vulnerability/CVE-2013-6418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6418/
Summaries are generated and may contain mistakes; the official description above is the record.
