# CVE-2013-6419: OpenStack Nova Router metadata queries are not restricted by tenant

> Remote tenants can obtain sensitive metadata by spoofing device IDs due to missing instance ID validation in OpenStack Nova and Neutron.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-6419, GHSA-22w9-j288-8p9w, PYSEC-2026-858, RHSA-2014:0091

## What is CVE-2013-6419?

CVE-2013-6419 is a medium-severity vulnerability in n/a, published on 7 Jan 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Interaction error in OpenStack Nova and Neutron before Havana 2013.2.1 and icehouse-1 does not validate the instance ID of the tenant making a request, which allows remote tenants to obtain sensitive metadata by spoofing the device ID that is bound to a port, which is not properly handled by (1) api/metadata/handler.py in Nova and (2) the neutron-metadata-agent (agent/metadata/agent.py) in Neutron.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2013-6419?

3 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `openstack-neutron` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-bigswitch` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-brocade` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-cisco` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-hyperv` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-linuxbridge` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-mellanox` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-metaplugin` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-metering-agent` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-midonet` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-ml2` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-nec` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-nicira` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-openvswitch` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-plumgrid` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-ryu` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `openstack-neutron-vpn-agent` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |
| `python-neutron` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.1-4.el6ost |

Products: Openstack Havana.

## How do I fix CVE-2013-6419?

Upgrade nova to 12.0.0a0 or later.

## Is CVE-2013-6419 being exploited?

There is no known exploitation of CVE-2013-6419 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6419 and fix it if it is affected.

What it is: CVE-2013-6419 is a medium-severity vulnerability in n/a, published on 7 Jan 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-6419 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 12.0.0a0
- nova (PyPI): affected all versions; fixed in 12.0.0a0
- nova (PyPI): affected all versions; fixed in 12.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6419/ (Markdown: https://insights.sbomify.com/CVE-2013-6419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6419
- OSV: https://osv.dev/vulnerability/CVE-2013-6419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6419/
Summaries are generated and may contain mistakes; the official description above is the record.
