# CVE-2013-6437: OpenStack Nova DoS through ephemeral disk backing files

> Remote authenticated users can cause denial of service via disk consumption by creating and deleting instances with unique os_type settings in OpenStack Compute.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Mar 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-6437, GHSA-hrv9-4x4c-9jc8, PYSEC-2026-874

## What is CVE-2013-6437?

CVE-2013-6437 is a medium-severity denial of service vulnerability in n/a, published on 6 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The libvirt driver in OpenStack Compute (Nova) before 2013.2.2 and icehouse before icehouse-2 allows remote authenticated users to cause a denial of service (disk consumption) by creating and deleting instances with unique os_type settings, which triggers the creation of a new ephemeral disk backing file.

Weakness: CWE-399

## Which versions are affected by CVE-2013-6437?

3 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `nova` | PyPI | All versions | 12.0.0a0 |
| `nova` | PyPI | All versions | 12.0.0a0 |

Products: Openstack Nova.

## How do I fix CVE-2013-6437?

Upgrade nova to 12.0.0a0 or later.

## Is CVE-2013-6437 being exploited?

There is no known exploitation of CVE-2013-6437 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-7214](https://insights.sbomify.com/CVE-2017-7214/): OpenStack Nova logs sensitive context from notification exceptions (critical 9.8)
- [CVE-2017-17051](https://insights.sbomify.com/CVE-2017-17051/): OpenStack Nova DoS by rebuilding the same instance with a new image multiple times (high 8.6)
- [CVE-2020-17376](https://insights.sbomify.com/CVE-2020-17376/): OpenStack Nova Live migration fails to update persistent domain XML (high 8.3)
- [CVE-2017-18191](https://insights.sbomify.com/CVE-2017-18191/): OpenStack Nova Denial of service attack on the compute host (high 7.5)
- [CVE-2015-3280](https://insights.sbomify.com/CVE-2015-3280/): OpenStack Compute (nova) allows remote authenticated users to cause a denial of service (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6437 and fix it if it is affected.

What it is: CVE-2013-6437 is a medium-severity denial of service vulnerability in n/a, published on 6 Mar 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-6437 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 12.0.0a0
- nova (PyPI): affected all versions; fixed in 12.0.0a0
- nova (PyPI): affected all versions; fixed in 12.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6437/ (Markdown: https://insights.sbomify.com/CVE-2013-6437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6437
- OSV: https://osv.dev/vulnerability/CVE-2013-6437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6437/
Summaries are generated and may contain mistakes; the official description above is the record.
