# CVE-2013-6440: Exposure of Sensitive Information to an Unauthorized Actor in OpenSAML

> Remote attackers can read sensitive data via XML external entity attacks in Shibboleth OpenSAML-Java due to unsafe entity expansion settings.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Feb 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v723-58jv-2qc4

## What is CVE-2013-6440?

CVE-2013-6440 is a medium-severity vulnerability in n/a, published on 14 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The (1) BasicParserPool, (2) StaticBasicParserPool, (3) XML Decrypter, and (4) SAML Decrypter in Shibboleth OpenSAML-Java before 2.6.1 set the expandEntityReferences property to true, which allows remote attackers to conduct XML external entity (XXE) attacks via a crafted XML DOCTYPE declaration.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2013-6440?

2 open source packages ship an affected version, including org.opensaml:opensaml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opensaml:opensaml` | Maven | All versions | 2.6.1 |
| `org.opensaml:opensaml` | Maven | All versions | 2.6.1 |

Products: Internet2 Opensaml, Shibboleth Opensaml.

## How do I fix CVE-2013-6440?

Upgrade org.opensaml:opensaml to 2.6.1 or later.

## Is CVE-2013-6440 being exploited?

There is no known exploitation of CVE-2013-6440 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2009-3476](https://insights.sbomify.com/CVE-2009-3476/): Memory corruption in n/a (critical 9.3)
- [CVE-2009-3474](https://insights.sbomify.com/CVE-2009-3474/): Security feature bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6440 and fix it if it is affected.

What it is: CVE-2013-6440 is a medium-severity vulnerability in n/a, published on 14 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-6440 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.1
- org.opensaml:opensaml (Maven): affected all versions; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6440/ (Markdown: https://insights.sbomify.com/CVE-2013-6440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6440
- OSV: https://osv.dev/vulnerability/CVE-2013-6440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6440/
Summaries are generated and may contain mistakes; the official description above is the record.
