# CVE-2013-6480: Libcloud does not properly scrub data when destroying a DigitalOcean node

> Local attackers can recover sensitive data from destroyed DigitalOcean VMs because Libcloud fails to scrub data during destruction.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-g892-9h8m-r69r, PYSEC-2014-97

## What is CVE-2013-6480?

CVE-2013-6480 is a low-severity vulnerability in n/a, published on 7 Jan 2014. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Libcloud 0.12.3 through 0.13.2 does not set the scrub_data parameter for the destroy DigitalOcean API, which allows local users to obtain sensitive information by leveraging a new VM.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2013-6480?

3 open source packages ship an affected version, including apache-libcloud. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-libcloud` | PyPI | From 0.12.3 | 0.13.3 |
| `apache-libcloud` | PyPI | From 0.12.3 | 0.13.3 |
| `apache-libcloud` | PyPI | From 0.12.3 | 0.13.3 |

Products: Apache Libcloud.

## How do I fix CVE-2013-6480?

Upgrade apache-libcloud to 0.13.3 or later.

## Is CVE-2013-6480 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-6480 exists.

Public exploit code:

- Apache Libcloud Digital Ocean API - Local Information Disclosure (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2012-3446](https://insights.sbomify.com/CVE-2012-3446/): Apache Libcloud vulnerable to certificate impersonation (medium 5.9)
- [CVE-2010-4340](https://insights.sbomify.com/CVE-2010-4340/): Apache Libcloud does not verify SSL certificates for HTTPS connections (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-6480 and fix it if it is affected.

What it is: CVE-2013-6480 is a low-severity vulnerability in n/a, published on 7 Jan 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-6480 exists.

Affected packages and fixed versions:
- apache-libcloud (PyPI): affected from 0.12.3; fixed in 0.13.3
- apache-libcloud (PyPI): affected from 0.12.3; fixed in 0.13.3
- apache-libcloud (PyPI): affected from 0.12.3; fixed in 0.13.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-6480/ (Markdown: https://insights.sbomify.com/CVE-2013-6480/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-6480
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-6480
- OSV: https://osv.dev/vulnerability/CVE-2013-6480

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-6480/
Summaries are generated and may contain mistakes; the official description above is the record.
