CVE-2013-7077 TYPO3 Cross-site scripting (XSS) vulnerability in the Backend User Administration Module

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML into the TYPO3 Backend User Administration Module, potentially compromising administrator accounts.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2013-7077?

CVE-2013-7077 is a medium-severity cross-site scripting vulnerability in Typo3 Typo3, published on 21 Dec 2013. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the Backend User Administration Module in TYPO3 6.0.x before 6.0.12 and 6.1.x before 6.1.7 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2013-7077?

4 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.

PackageAffectedFixed in
typo3/cms-core PackagistFrom 6.06.0.12
typo3/cms-core PackagistFrom 6.06.0.12
typo3/cms-core PackagistFrom 6.16.1.7
typo3/cms-core PackagistFrom 6.16.1.7

Products include Typo3 Typo3.

How do I fix CVE-2013-7077?

Upgrade typo3/cms-core to a fixed version for your release line: 6.0.12 or 6.1.7.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2013-7077 being exploited?

There is no known exploitation of CVE-2013-7077 in the wild and no public exploit code.

All Typo3 Typo3 vulnerabilities

Sources

Also known as GHSA-5cmc-r23m-hvrr.

Is CVE-2013-7077 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free