# CVE-2013-7078: TYPO3 Cross-site scripting (XSS) vulnerability in the Extbase Framework

> Remote attackers can inject arbitrary web script or HTML via error messages in TYPO3 when the Rewritten Property Mapper is enabled.

- **Severity:** Low 2.6 (`AV:N/AC:H/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qj69-chjp-g4f5

## What is CVE-2013-7078?

CVE-2013-7078 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 19 Jan 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the errorAction method in the ActionController base class in the Extbase Framework in TYPO3 4.5.0 through 4.5.31, 4.7.0 through 4.7.16, 6.0.0 through 6.0.11, and 6.1.0 through 6.1.6, when the Rewritten Property Mapper is enabled, allows remote attackers to inject arbitrary web script or HTML via unspecified input, which is returned in an error message.  NOTE: this might be the same vulnerability as CVE-2013-7072.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-7078?

8 open source packages ship an affected version, including typo3/cms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 4.5.0 | 4.5.31 |
| `typo3/cms-core` | Packagist | From 4.5.0 | 4.5.31 |
| `typo3/cms-core` | Packagist | From 4.7.0 | 4.7.16 |
| `typo3/cms-core` | Packagist | From 4.7.0 | 4.7.16 |
| `typo3/cms-core` | Packagist | From 6.0.0 | 6.0.11 |
| `typo3/cms-core` | Packagist | From 6.0.0 | 6.0.11 |
| `typo3/cms-core` | Packagist | From 6.1.0 | 6.1.6 |
| `typo3/cms-core` | Packagist | From 6.1.0 | 6.1.6 |

Products: Typo3 Typo3.

## How do I fix CVE-2013-7078?

Upgrade typo3/cms-core to a fixed version for your release line: 4.5.31, 4.7.16, 6.0.11 or 6.1.6.

## Is CVE-2013-7078 being exploited?

There is no known exploitation of CVE-2013-7078 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-7078 and fix it if it is affected.

What it is: CVE-2013-7078 is a low-severity cross-site scripting vulnerability in Typo3 Typo3, published on 19 Jan 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-7078 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 4.5.0; fixed in 4.5.31
- typo3/cms-core (Packagist): affected from 4.5.0; fixed in 4.5.31
- typo3/cms-core (Packagist): affected from 4.7.0; fixed in 4.7.16
- typo3/cms-core (Packagist): affected from 4.7.0; fixed in 4.7.16
- typo3/cms-core (Packagist): affected from 6.0.0; fixed in 6.0.11
- typo3/cms-core (Packagist): affected from 6.0.0; fixed in 6.0.11
- typo3/cms-core (Packagist): affected from 6.1.0; fixed in 6.1.6
- typo3/cms-core (Packagist): affected from 6.1.0; fixed in 6.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-7078/ (Markdown: https://insights.sbomify.com/CVE-2013-7078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-7078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-7078
- OSV: https://osv.dev/vulnerability/CVE-2013-7078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-7078/
Summaries are generated and may contain mistakes; the official description above is the record.
