# CVE-2013-7079: TYPO3 OpenID extension Open redirect vulnerability

> Remote attackers can redirect users to arbitrary sites for phishing via the OpenID extension in TYPO3.

- **Severity:** Medium 5.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Dec 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-838c-v5cq-hp33

## What is CVE-2013-7079?

CVE-2013-7079 is a medium-severity vulnerability in Typo3 Typo3, published on 23 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open redirect vulnerability in the OpenID extension in TYPO3 4.5.0 through 4.5.31, 4.7.0 through 4.7.16, 6.0.0 through 6.0.11, and 6.1.0 through 6.1.6 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-7079?

8 open source packages ship an affected version, including friendsoftypo3/openid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `friendsoftypo3/openid` | Packagist | From 4.5.0 | 4.5.31 |
| `friendsoftypo3/openid` | Packagist | From 4.5.0 | 4.5.31 |
| `friendsoftypo3/openid` | Packagist | From 4.7.0 | 4.7.16 |
| `friendsoftypo3/openid` | Packagist | From 4.7.0 | 4.7.16 |
| `friendsoftypo3/openid` | Packagist | From 6.0.0 | 6.0.11 |
| `friendsoftypo3/openid` | Packagist | From 6.0.0 | 6.0.11 |
| `friendsoftypo3/openid` | Packagist | From 6.1.0 | 6.1.6 |
| `friendsoftypo3/openid` | Packagist | From 6.1.0 | 6.1.6 |

Products: Typo3 Typo3.

## How do I fix CVE-2013-7079?

Upgrade friendsoftypo3/openid to a fixed version for your release line: 4.5.31, 4.7.16, 6.0.11 or 6.1.6.

## Is CVE-2013-7079 being exploited?

There is no known exploitation of CVE-2013-7079 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-7079 and fix it if it is affected.

What it is: CVE-2013-7079 is a medium-severity vulnerability in Typo3 Typo3, published on 23 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-7079 in the wild and no public exploit code.

Affected packages and fixed versions:
- friendsoftypo3/openid (Packagist): affected from 4.5.0; fixed in 4.5.31
- friendsoftypo3/openid (Packagist): affected from 4.5.0; fixed in 4.5.31
- friendsoftypo3/openid (Packagist): affected from 4.7.0; fixed in 4.7.16
- friendsoftypo3/openid (Packagist): affected from 4.7.0; fixed in 4.7.16
- friendsoftypo3/openid (Packagist): affected from 6.0.0; fixed in 6.0.11
- friendsoftypo3/openid (Packagist): affected from 6.0.0; fixed in 6.0.11
- friendsoftypo3/openid (Packagist): affected from 6.1.0; fixed in 6.1.6
- friendsoftypo3/openid (Packagist): affected from 6.1.0; fixed in 6.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-7079/ (Markdown: https://insights.sbomify.com/CVE-2013-7079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-7079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-7079
- OSV: https://osv.dev/vulnerability/CVE-2013-7079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-7079/
Summaries are generated and may contain mistakes; the official description above is the record.
