CVE-2013-7082 TYPO3 Flow Cross-site scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script or HTML via unspecified input in TYPO3 Flow error messages, requiring user interaction to execute.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2013-7082?
CVE-2013-7082 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the errorAction method in the ActionController base class in TYPO3 Flow (formerly FLOW3) 1.1.x before 1.1.1 and 2.0.x before 2.0.1 allows remote attackers to inject arbitrary web script or HTML via unspecified input, which is returned in an error message.
Weakness: CWE-79
Which versions are affected by CVE-2013-7082?
8 open source packages ship an affected version, including neos/flow and typo3/flow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
neos/flow Packagist | From 1.1.0 | 1.1.1 |
neos/flow Packagist | From 1.1.0 | 1.1.1 |
neos/flow Packagist | From 2.0.0 | 2.0.1 |
neos/flow Packagist | From 2.0.0 | 2.0.1 |
typo3/flow Packagist | From 1.1.0 | 1.1.1 |
typo3/flow Packagist | From 1.1.0 | 1.1.1 |
2 more packages
typo3/flow Packagist | From 2.0.0 | 2.0.1 |
typo3/flow Packagist | From 2.0.0 | 2.0.1 |
Products include Typo3 Flow.
How do I fix CVE-2013-7082?
Upgrade neos/flow to a fixed version for your release line: 1.1.1 or 2.0.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2013-7082 being exploited?
There is no known exploitation of CVE-2013-7082 in the wild and no public exploit code.
Sources
Also known as GHSA-vc74-c4m6-9979.