# CVE-2013-7082: TYPO3 Flow Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML via unspecified input in TYPO3 Flow error messages, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2013
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vc74-c4m6-9979

## What is CVE-2013-7082?

CVE-2013-7082 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the errorAction method in the ActionController base class in TYPO3 Flow (formerly FLOW3) 1.1.x before 1.1.1 and 2.0.x before 2.0.1 allows remote attackers to inject arbitrary web script or HTML via unspecified input, which is returned in an error message.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-7082?

8 open source packages ship an affected version, including neos/flow and typo3/flow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neos/flow` | Packagist | From 1.1.0 | 1.1.1 |
| `neos/flow` | Packagist | From 1.1.0 | 1.1.1 |
| `neos/flow` | Packagist | From 2.0.0 | 2.0.1 |
| `neos/flow` | Packagist | From 2.0.0 | 2.0.1 |
| `typo3/flow` | Packagist | From 1.1.0 | 1.1.1 |
| `typo3/flow` | Packagist | From 1.1.0 | 1.1.1 |
| `typo3/flow` | Packagist | From 2.0.0 | 2.0.1 |
| `typo3/flow` | Packagist | From 2.0.0 | 2.0.1 |

Products: Typo3 Flow.

## How do I fix CVE-2013-7082?

Upgrade neos/flow to a fixed version for your release line: 1.1.1 or 2.0.1.

## Is CVE-2013-7082 being exploited?

There is no known exploitation of CVE-2013-7082 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-7082 and fix it if it is affected.

What it is: CVE-2013-7082 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Dec 2013. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2013-7082 in the wild and no public exploit code.

Affected packages and fixed versions:
- neos/flow (Packagist): affected from 1.1.0; fixed in 1.1.1
- neos/flow (Packagist): affected from 1.1.0; fixed in 1.1.1
- neos/flow (Packagist): affected from 2.0.0; fixed in 2.0.1
- neos/flow (Packagist): affected from 2.0.0; fixed in 2.0.1
- typo3/flow (Packagist): affected from 1.1.0; fixed in 1.1.1
- typo3/flow (Packagist): affected from 1.1.0; fixed in 1.1.1
- typo3/flow (Packagist): affected from 2.0.0; fixed in 2.0.1
- typo3/flow (Packagist): affected from 2.0.0; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-7082/ (Markdown: https://insights.sbomify.com/CVE-2013-7082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-7082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-7082
- OSV: https://osv.dev/vulnerability/CVE-2013-7082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-7082/
Summaries are generated and may contain mistakes; the official description above is the record.
