CVE-2013-7110 Transifex command-line client has improper certificate validation

Medium 4.3 Published Updated

Man-in-the-middle attackers can spoof Transifex servers due to missing X.509 certificate validation in the command-line client.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-7110?

CVE-2013-7110 is a medium-severity vulnerability in n/a, published on 2 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Transifex command-line client before 0.10 does not validate X.509 certificates for data transfer connections, which allows man-in-the-middle attackers to spoof a Transifex server via an arbitrary certificate. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-2073.

Weakness: CWE-20

Which versions are affected by CVE-2013-7110?

3 open source packages ship an affected version, including transifex-client. It affects 1 product.

PackageAffectedFixed in
transifex-client PyPIAll versions0.10
transifex-client PyPIAll versions0.10
transifex-client PyPIAll versions0.11.0

Products include Transifex Transifex.

How do I fix CVE-2013-7110?

Upgrade transifex-client to a fixed version for your release line: 0.10 or 0.11.0.

Is CVE-2013-7110 being exploited?

There is no known exploitation of CVE-2013-7110 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2013-7110, GHSA-jf99-2rj4-jxrm, PYSEC-2014-72, UBUNTU-CVE-2013-7110.

Is CVE-2013-7110 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free