{"answers":{"affected":"3 open source packages ship an affected version, including transifex-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-7110 in the wild and no public exploit code.","fix":"Upgrade transifex-client to a fixed version for your release line: 0.10 or 0.11.0.","what":"CVE-2013-7110 is a medium-severity vulnerability in n/a, published on 2 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-7110 and fix it if it is affected.\n\nWhat it is: CVE-2013-7110 is a medium-severity vulnerability in n/a, published on 2 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-7110 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- transifex-client (PyPI): affected all versions; fixed in 0.10\n- transifex-client (PyPI): affected all versions; fixed in 0.10\n- transifex-client (PyPI): affected all versions; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-7110/ (Markdown: https://insights.sbomify.com/CVE-2013-7110/index.md)","id":"CVE-2013-7110","markdown":"https://insights.sbomify.com/CVE-2013-7110/index.md","name":"CVE-2013-7110","record":{"aliases":["DEBIAN-CVE-2013-7110","GHSA-jf99-2rj4-jxrm","PYSEC-2014-72","UBUNTU-CVE-2013-7110"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Transifex CLI client","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof Transifex servers due to missing X.509 certificate validation in the command-line client.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"transifex","vendor":"transifex"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Transifex command-line client before 0.10 does not validate X.509 certificates for data transfer connections, which allows man-in-the-middle attackers to spoof a Transifex server via an arbitrary certificate.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-2073.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Transifex command-line client has improper certificate validation","id":"CVE-2013-7110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2013"},"n_packages":3,"n_references":3,"next":{"headline":"Exposure of Sensitive Information in bio-basespace-sdk","id":"CVE-2013-7111"},"packages":[{"ecosystem":"PyPI","fixed":["0.10"],"introduced":["0"],"last_affected":[],"package":"transifex-client","purl":null,"source":"GHSA-jf99-2rj4-jxrm"},{"ecosystem":"PyPI","fixed":["0.10"],"introduced":["0"],"last_affected":[],"package":"transifex-client","purl":"pkg:pypi/transifex-client","source":"GHSA-jf99-2rj4-jxrm"},{"ecosystem":"PyPI","fixed":["0.11.0"],"introduced":["0"],"last_affected":[],"package":"transifex-client","purl":"pkg:pypi/transifex-client","source":"PYSEC-2014-72"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2013-7109"},"products":["n/a"],"published":"2014-05-02","related":[{"cvss_score":4.3,"headline":"Security feature bypass in n/a","id":"CVE-2013-2073","kev_date_added":null,"published":"2014-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof Transifex servers due to missing X.509 certificate validation in the command-line client.","url":"https://insights.sbomify.com/CVE-2013-7110/"}