# CVE-2013-7110: Transifex command-line client has improper certificate validation

> Man-in-the-middle attackers can spoof Transifex servers due to missing X.509 certificate validation in the command-line client.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2013-7110, GHSA-jf99-2rj4-jxrm, PYSEC-2014-72, UBUNTU-CVE-2013-7110

## What is CVE-2013-7110?

CVE-2013-7110 is a medium-severity vulnerability in n/a, published on 2 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Transifex command-line client before 0.10 does not validate X.509 certificates for data transfer connections, which allows man-in-the-middle attackers to spoof a Transifex server via an arbitrary certificate.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-2073.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2013-7110?

3 open source packages ship an affected version, including transifex-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `transifex-client` | PyPI | All versions | 0.10 |
| `transifex-client` | PyPI | All versions | 0.10 |
| `transifex-client` | PyPI | All versions | 0.11.0 |

Products: Transifex Transifex.

## How do I fix CVE-2013-7110?

Upgrade transifex-client to a fixed version for your release line: 0.10 or 0.11.0.

## Is CVE-2013-7110 being exploited?

There is no known exploitation of CVE-2013-7110 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-2073](https://insights.sbomify.com/CVE-2013-2073/): Security feature bypass in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-7110 and fix it if it is affected.

What it is: CVE-2013-7110 is a medium-severity vulnerability in n/a, published on 2 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-7110 in the wild and no public exploit code.

Affected packages and fixed versions:
- transifex-client (PyPI): affected all versions; fixed in 0.10
- transifex-client (PyPI): affected all versions; fixed in 0.10
- transifex-client (PyPI): affected all versions; fixed in 0.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-7110/ (Markdown: https://insights.sbomify.com/CVE-2013-7110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-7110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-7110
- OSV: https://osv.dev/vulnerability/CVE-2013-7110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-7110/
Summaries are generated and may contain mistakes; the official description above is the record.
