CVE-2013-7285 Command Injection in Xstream

Critical 9.8 Published Updated

Remote attackers can execute arbitrary shell commands via manipulated input streams in XStream if the security framework is not initialized.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-7285?

CVE-2013-7285 is a critical command injection vulnerability in Apache Activemq, published on 15 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not been initialized, may allow a remote attacker to run arbitrary shell commands by manipulating the processed input stream when unmarshaling XML or any supported format. e.g. JSON.

Weakness: CWE-78

Which versions are affected by CVE-2013-7285?

4 open source packages ship an affected version, including com.thoughtworks.xstream:xstream. It affects 3 products.

PackageAffectedFixed in
com.thoughtworks.xstream:xstream MavenAll versions1.4.7
com.thoughtworks.xstream:xstream MavenAll versions1.4.7
com.thoughtworks.xstream:xstream MavenFrom 1.4.101.4.11
com.thoughtworks.xstream:xstream MavenFrom 1.4.101.4.11
Linux distribution packages (1)
jasperreports-server-pro Red Hat:rhev_manager:3All versions0:5.5.0-6.el6ev

Products include Apache Activemq, Oracle Endeca Information Discovery Studio, Xstream Xstream.

How do I fix CVE-2013-7285?

Upgrade com.thoughtworks.xstream:xstream to a fixed version for your release line: 1.4.7 or 1.4.11.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2013-7285 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2013-7285 exists.

Public exploit code: 1 Exploit-DB entry, 1 Nuclei template and 1 proofs of concept on GitHub.

All Apache Activemq vulnerabilities

Sources

Also known as DEBIAN-CVE-2013-7285, GHSA-f554-x222-wgf7, MGASA-2014-0100, RHSA-2014:0389, UBUNTU-CVE-2013-7285.

Is CVE-2013-7285 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free