CVE-2013-7323 python-gnupg allows context-dependent attackers to execute arbitrary commands via shell metacharacters
High 7.5
Published
Updated
Check this codebase for CVE-2013-7323 and fix it if it is affected.
What it is: CVE-2013-7323 is a high-severity vulnerability in n/a, published on 9 Jun 2014.
Exploitation: There is no known exploitation of CVE-2013-7323 in the wild and no public exploit code.
Affected packages and fixed versions:
- python-gnupg (PyPI): affected all versions; fixed in 0.3.5
- python-gnupg (PyPI): affected all versions; fixed in 0.3.7
- python-gnupg (PyPI): affected all versions; fixed in 0.3.7
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2013-7323/ (Markdown: https://insights.sbomify.com/CVE-2013-7323/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2013-7323?
CVE-2013-7323 is a high-severity vulnerability in n/a, published on 9 Jun 2014.
Official description
python-gnupg before 0.3.5 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.
Which versions are affected by CVE-2013-7323?
3 open source packages ship an affected version, including python-gnupg. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
python-gnupg PyPI | All versions | 0.3.5 |
python-gnupg PyPI | All versions | 0.3.7 |
python-gnupg PyPI | All versions | 0.3.7 |
Products include Vinay Sajip Python-Gnupg.
How do I fix CVE-2013-7323?
Upgrade python-gnupg to a fixed version for your release line: 0.3.5 or 0.3.7.
Is CVE-2013-7323 being exploited?
There is no known exploitation of CVE-2013-7323 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2013-7323, GHSA-c2fx-8r76-gh36, PYSEC-2014-89, UBUNTU-CVE-2013-7323.