CVE-2013-7330 Jenkins allows attackers to configure restricted projects

Medium 4.0 Published Updated

Authenticated users can bypass restrictions to configure projects via post-build actions, requiring an upgrade to Jenkins.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2013-7330?

CVE-2013-7330 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 17 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.502 allows remote authenticated users to configure an otherwise restricted project via vectors related to post-build actions.

Weakness: CWE-264

Which versions are affected by CVE-2013-7330?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.480.3
org.jenkins-ci.main:jenkins-core MavenAll versions1.480.3
org.jenkins-ci.main:jenkins-core MavenFrom 1.4811.502
org.jenkins-ci.main:jenkins-core MavenFrom 1.4811.502

Products include Jenkins Jenkins.

How do I fix CVE-2013-7330?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.480.3 or 1.502.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2013-7330 being exploited?

There is no known exploitation of CVE-2013-7330 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-h5jv-hg68-mjhg.

Is CVE-2013-7330 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free