{"answers":{"affected":"2 open source packages ship an affected version, including connect. It affects 2 products.","exploited":"There is no known exploitation of CVE-2013-7371 in the wild and no public exploit code.","fix":"Upgrade connect to 2.8.2 or later.","what":"CVE-2013-7371 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-7371 and fix it if it is affected.\n\nWhat it is: CVE-2013-7371 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Dec 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-7371 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- connect (npm): affected all versions; fixed in 2.8.2\n- connect (npm): affected all versions; fixed in 2.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-7371/ (Markdown: https://insights.sbomify.com/CVE-2013-7371/index.md)","id":"CVE-2013-7371","markdown":"https://insights.sbomify.com/CVE-2013-7371/index.md","name":"CVE-2013-7371","record":{"aliases":["GHSA-6w62-83g6-rfhj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Connect middleware","requires_auth":"none","summary":"Cross-site scripting vulnerability in node-connect allows attackers to inject malicious scripts into web pages viewed by other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"connect","vendor":"sencha"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Node Connect Reflected Cross-Site Scripting in Sencha Labs Connect middleware","id":"CVE-2013-7371","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"xss","year":"2013"},"n_packages":2,"n_references":6,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2013-7372"},"packages":[{"ecosystem":"npm","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"connect","purl":null,"source":"GHSA-6w62-83g6-rfhj"},{"ecosystem":"npm","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"connect","purl":"pkg:npm/connect","source":"GHSA-6w62-83g6-rfhj"}],"prev":{"headline":"methodOverride Middleware Reflected Cross-Site Scripting in connect","id":"CVE-2013-7370"},"products":["node-connect"],"published":"2019-12-11","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["node-connect"]},"summary":"Cross-site scripting vulnerability in node-connect allows attackers to inject malicious scripts into web pages viewed by other users.","url":"https://insights.sbomify.com/CVE-2013-7371/"}