{"answers":{"affected":"2 open source packages ship an affected version, including codem-transcode. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-7377 in the wild and no public exploit code.","fix":"Upgrade codem-transcode to 0.5.0 or later.","what":"CVE-2013-7377 is a high-severity command injection vulnerability in n/a, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2013-7377 and fix it if it is affected.\n\nWhat it is: CVE-2013-7377 is a high-severity command injection vulnerability in n/a, published on 23 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2013-7377 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codem-transcode (npm): affected all versions; fixed in 0.5.0\n- codem-transcode (npm): affected all versions; fixed in 0.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-7377/ (Markdown: https://insights.sbomify.com/CVE-2013-7377/index.md)","id":"CVE-2013-7377","markdown":"https://insights.sbomify.com/CVE-2013-7377/index.md","name":"CVE-2013-7377","record":{"aliases":["GHSA-rph7-j9qr-h8q8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js transcode library","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via a POST request if ffprobe is enabled in the codem-transcode Node.js module.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"codem-transcode","vendor":"codem-transcode_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"The codem-transcode module before 0.5.0 for Node.js, when ffprobe is enabled, allows remote attackers to execute arbitrary commands via a POST request to /probe.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Potential Command Injection in codem-transcode","id":"CVE-2013-7377","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2013"},"n_packages":2,"n_references":3,"next":{"headline":"Potential Command Injection in hubot-scripts","id":"CVE-2013-7378"},"packages":[{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"codem-transcode","purl":null,"source":"GHSA-rph7-j9qr-h8q8"},{"ecosystem":"npm","fixed":["0.5.0"],"introduced":["0"],"last_affected":[],"package":"codem-transcode","purl":"pkg:npm/codem-transcode","source":"GHSA-rph7-j9qr-h8q8"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2013-7376"},"products":["n/a"],"published":"2017-10-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via a POST request if ffprobe is enabled in the codem-transcode Node.js module.","url":"https://insights.sbomify.com/CVE-2013-7377/"}