# CVE-2013-7378: Potential Command Injection in hubot-scripts

> Remote attackers can execute arbitrary commands via the email script in the Hubot Scripts library for Node.js.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-hwch-749c-rv63

## What is CVE-2013-7378?

CVE-2013-7378 is a critical command injection vulnerability in n/a, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

scripts/email.coffee in the Hubot Scripts module before 2.4.4 for Node.js allows remote attackers to execute arbitrary commands.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2013-7378?

2 open source packages ship an affected version, including hubot-scripts. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hubot-scripts` | npm | All versions | 2.4.5 |
| `hubot-scripts` | npm | All versions | 2.4.5 |

Products: Hubot Scripts Project Hubot Scripts.

## How do I fix CVE-2013-7378?

Upgrade hubot-scripts to 2.4.5 or later.

## Is CVE-2013-7378 being exploited?

There is no known exploitation of CVE-2013-7378 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-7378 and fix it if it is affected.

What it is: CVE-2013-7378 is a critical command injection vulnerability in n/a, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-7378 in the wild and no public exploit code.

Affected packages and fixed versions:
- hubot-scripts (npm): affected all versions; fixed in 2.4.5
- hubot-scripts (npm): affected all versions; fixed in 2.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-7378/ (Markdown: https://insights.sbomify.com/CVE-2013-7378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-7378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-7378
- OSV: https://osv.dev/vulnerability/CVE-2013-7378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-7378/
Summaries are generated and may contain mistakes; the official description above is the record.
