# CVE-2013-7381: Potential Command Injection in libnotify

> Remote attackers can execute arbitrary commands via unspecified characters in libnotify.notify calls in Node.js.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6898-wx94-8jq8

## What is CVE-2013-7381?

CVE-2013-7381 is a critical command injection vulnerability in n/a, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libnotify before 1.0.4 for Node.js allows remote attackers to execute arbitrary commands via unspecified characters in a call to libnotify.notify.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2013-7381?

2 open source packages ship an affected version, including libnotify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libnotify` | npm | All versions | 1.0.4 |
| `libnotify` | npm | All versions | 1.0.4 |

Products: Libnotify Project Libnotify.

## How do I fix CVE-2013-7381?

Upgrade libnotify to 1.0.4 or later.

## Is CVE-2013-7381 being exploited?

There is no known exploitation of CVE-2013-7381 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-7381 and fix it if it is affected.

What it is: CVE-2013-7381 is a critical command injection vulnerability in n/a, published on 12 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2013-7381 in the wild and no public exploit code.

Affected packages and fixed versions:
- libnotify (npm): affected all versions; fixed in 1.0.4
- libnotify (npm): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-7381/ (Markdown: https://insights.sbomify.com/CVE-2013-7381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-7381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-7381
- OSV: https://osv.dev/vulnerability/CVE-2013-7381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-7381/
Summaries are generated and may contain mistakes; the official description above is the record.
