{"answers":{"affected":"2 open source packages ship an affected version, including validator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2013-7451 in the wild and no public exploit code.","fix":"Upgrade validator to 1.1.0 or later.","what":"CVE-2013-7451 is a medium-severity cross-site scripting vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2013-7451 and fix it if it is affected.\n\nWhat it is: CVE-2013-7451 is a medium-severity cross-site scripting vulnerability in Nodejs Node.js, published on 23 Jan 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2013-7451 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- validator (npm): affected all versions; fixed in 1.1.0\n- validator (npm): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2013-7451/ (Markdown: https://insights.sbomify.com/CVE-2013-7451/index.md)","id":"CVE-2013-7451","markdown":"https://insights.sbomify.com/CVE-2013-7451/index.md","name":"CVE-2013-7451","record":{"aliases":["GHSA-qpjp-7rp2-9c3f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js validator module","requires_auth":"none","summary":"Remote attackers can bypass the XSS filter in the Node.js validator module by using nested tags, potentially allowing script injection.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"node.js","vendor":"nodejs"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The validator module before 1.1.0 for Node.js allows remote attackers to bypass the XSS filter via a nested tag.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects validator","id":"CVE-2013-7451","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:node.js","products":["nodejs:node.js"],"type":"xss","year":"2013"},"n_packages":2,"n_references":2,"next":{"headline":"Moderate severity vulnerability that affects validator","id":"CVE-2013-7452"},"packages":[{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"validator","purl":null,"source":"GHSA-qpjp-7rp2-9c3f"},{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"validator","purl":"pkg:npm/validator","source":"GHSA-qpjp-7rp2-9c3f"}],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2013-7450"},"products":["n/a"],"published":"2017-01-23","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass the XSS filter in the Node.js validator module by using nested tags, potentially allowing script injection.","url":"https://insights.sbomify.com/CVE-2013-7451/"}