# CVE-2013-7452: Moderate severity vulnerability that affects validator


- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-rh6c-q938-3r9q

## What is CVE-2013-7452?

CVE-2013-7452 is a medium-severity vulnerability in Nodejs Node.js, published on 23 Jan 2017. 

### Official description

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via a crafted javascript URI.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2013-7452?

2 open source packages ship an affected version, including validator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `validator` | npm | All versions | 1.1.0 |
| `validator` | npm | All versions | 1.1.0 |

Products: Nodejs Node.js.

## How do I fix CVE-2013-7452?

Upgrade validator to 1.1.0 or later.

## Is CVE-2013-7452 being exploited?

There is no known exploitation of CVE-2013-7452 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Node.js

- [CVE-2023-32002](https://insights.sbomify.com/CVE-2023-32002/): Security feature bypass in Node (critical 9.8)
- [CVE-2016-6303](https://insights.sbomify.com/CVE-2016-6303/): Integer overflow in n/a (critical 9.8)
- [CVE-2017-15896](https://insights.sbomify.com/CVE-2017-15896/): Security feature bypass in Node.js (critical 9.1)
- [CVE-2018-7160](https://insights.sbomify.com/CVE-2018-7160/): Server-side request forgery in Node.js (high 8.8)
- [CVE-2018-12120](https://insights.sbomify.com/CVE-2018-12120/): Misconfiguration in Node.js (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2013-7452 and fix it if it is affected.

What it is: CVE-2013-7452 is a medium-severity vulnerability in Nodejs Node.js, published on 23 Jan 2017. 
Exploitation: There is no known exploitation of CVE-2013-7452 in the wild and no public exploit code.

Affected packages and fixed versions:
- validator (npm): affected all versions; fixed in 1.1.0
- validator (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2013-7452/ (Markdown: https://insights.sbomify.com/CVE-2013-7452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2013-7452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2013-7452
- OSV: https://osv.dev/vulnerability/CVE-2013-7452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2013-7452/
Summaries are generated and may contain mistakes; the official description above is the record.
