CVE-2014-0003 Apache Camel's XSLT component allows remote attackers to execute arbitrary Java methods

High 7.5 Published Updated

Remote attackers can execute arbitrary Java methods in Apache Camel via crafted messages, requiring immediate upgrades to secure integration flows.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-0003?

CVE-2014-0003 is a high-severity code injection vulnerability in Apache Camel, published on 20 Mar 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The XSLT component in Apache Camel 2.11.x before 2.11.4, 2.12.x before 2.12.3, and possibly earlier versions allows remote attackers to execute arbitrary Java methods via a crafted message.

Weakness: CWE-264

Which versions are affected by CVE-2014-0003?

4 open source packages ship an affected version, including org.apache.camel:camel-core. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-core MavenFrom 2.11.02.11.4
org.apache.camel:camel-core MavenFrom 2.11.02.11.4
org.apache.camel:camel-core MavenFrom 2.12.02.12.3
org.apache.camel:camel-core MavenFrom 2.12.02.12.3

Products include Apache Camel.

How do I fix CVE-2014-0003?

Upgrade org.apache.camel:camel-core to a fixed version for your release line: 2.11.4 or 2.12.3.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2014-0003 being exploited?

There is no known exploitation of CVE-2014-0003 in the wild and no public exploit code.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-h6rp-8v4j-hwph.

Is CVE-2014-0003 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free